Witamy, Gość. Zaloguj się lub zarejestruj.
Czy dotarł do Ciebie email aktywacyjny?


Zaloguj się podając nazwę użytkownika, hasło i długość sesji

Polskie Forum Użytkowników GIMP-aOgólne dyskusjeDyskusjeInkscapeWątek: Czego Wam brakuje, co chcielibyście zmienić
Strony: 1 [2] 3 4  Wszystkie
DrukujPobierz PDF
Autor Wątek: Czego Wam brakuje, co chcielibyście zmienić  (Przeczytany 42425 razy)
0 użytkowników i 1 Gość przegląda ten wątek.
Elfica
Użytkownik

Reputacja: 2 Offline Offline

Płeć: Kobieta
GIMP: 2.4
JID: elfiatko@jabster.pl
Licencja: Copyright
Wiadomości: 61
Galeria Użytkownika



Zobacz profil
« Odpowiedz #14 : 05.06.2008, 14:48:49 »

RRH, no nie skompiluję drania na razie - strasznie dużo szarpania się z zależnościami, ciągle mi coś nowego wywala :/ A jeszcze upgrade do Fedory 9 mnie czeka na dniach :) (w końcu :)) Spróbuję w przyszłym tygodniu bo w tym już mi się nie chce, muszę odpocząć...

Muszę się przyjrzeć temu SVN, nigdy przez to nic nie robiłam, no ale jak mam takie jazdy z zależnościami to nie wiem, czy jest sens :)

A co do włączania/wyłączania warstw, to też jestem za, klikanie denerwuje :)
Zapisane

RRH
Gość
« Odpowiedz #15 : 05.06.2008, 15:56:21 »

Widzisz, dlatego paczki .deb mają tą przewagę nad .rmp, że nie trzeba aż tak się męczyć z zależnościami. Mrugnięcie
Co do svn, ściąganie źródeł wygląda tak:

Kod:
svn co https://inkscape.svn.sourceforge.net/svnroot/inkscape/inkscape/trunk inkscape

wcześniej zakładasz sobie katalog inkscape.

Aktualizujesz tak:
Kod:
svn up https://inkscape.svn.sourceforge.net/svnroot/inkscape/inkscape/trunk inkscape

później uruchamiasz skrypt autogen.sh i już tradycyjnie:

Kod:
./configure --prefix=/usr/local
make
make instal

lepiej zainstalować w /usr/local, żeby mieć w systemie stabilną wersję i nie nadpisać tej z paczki.
Ja na Debianie, mam bardzo łatwo. Wydaję:
Kod:
apt-get build-dep inkscape
i instaluje mi paczki potrzebne do skompilowania Inkscape'a. Jeszcze się pluło o jakąś bibliotekę. Zainstalowałem ją i fajrant. Teraz nie mam problemów.

Warto spróbować. Powodzenia. Uśmiech

//edit
Może to Ci się przyda. Co prawda to nazwy paczek deb, ale możesz poszukać analogicznych rpm:

Kod:
Inst aspell [0.60.5-2] (0.60.5-2.2 Debian:testing) []
Inst libaspell15 [0.60.5-2] (0.60.5-2.2 Debian:testing)
Inst libaspell-dev (0.60.5-2.2 Debian:testing)
Inst libbz2-dev (1.0.5-0.1 Debian:testing)
Inst libdjvulibre-dev (3.5.20-6 Debian:testing)
Inst libgraphviz4 [2.16.1-3] (2.18-1+b1 Debian:testing)
Inst libgraphviz-dev (2.18-1+b1 Debian:testing)
Inst libgsf-1-dev (1.14.8-1 Debian:testing)
Inst libgtkspell-dev (2.0.10-4 Debian:testing)
Inst libilmbase-dev (1.0.1-2 Debian:testing)
Inst libjasper1 [1.900.1-3] (1.900.1-4 Debian:testing)
Inst libjasper-dev (1.900.1-4 Debian:testing)
Inst libmagick10 [7:6.3.7.9.dfsg1-2+b1] (7:6.3.7.9.dfsg1-2+b2 Debian:testing)
Inst libmagick++10 [7:6.3.7.9.dfsg1-2+b1] (7:6.3.7.9.dfsg1-2+b2 Debian:testing)
Inst libopenexr-dev (1.6.1-3 Debian:testing)
Inst libmagick9-dev (7:6.3.7.9.dfsg1-2+b2 Debian:testing)
Inst libmagick++9-dev (7:6.3.7.9.dfsg1-2+b2 Debian:testing)
Inst libwpd-stream8c2a (0.8.14-1 Debian:testing)
Inst libwpd8-dev (0.8.14-1 Debian:testing)
Inst libwpg-dev (0.1.2-1 Debian:testing)
Conf libaspell15 (0.60.5-2.2 Debian:testing)
Conf aspell (0.60.5-2.2 Debian:testing)
Conf libaspell-dev (0.60.5-2.2 Debian:testing)
Conf libbz2-dev (1.0.5-0.1 Debian:testing)
Conf libdjvulibre-dev (3.5.20-6 Debian:testing)
Conf libgraphviz4 (2.18-1+b1 Debian:testing)
Conf libgraphviz-dev (2.18-1+b1 Debian:testing)
Conf libgsf-1-dev (1.14.8-1 Debian:testing)
Conf libgtkspell-dev (2.0.10-4 Debian:testing)
Conf libilmbase-dev (1.0.1-2 Debian:testing)
Conf libjasper1 (1.900.1-4 Debian:testing)
Conf libjasper-dev (1.900.1-4 Debian:testing)
Conf libmagick10 (7:6.3.7.9.dfsg1-2+b2 Debian:testing)
Conf libmagick++10 (7:6.3.7.9.dfsg1-2+b2 Debian:testing)
Conf libopenexr-dev (1.6.1-3 Debian:testing)
Conf libmagick9-dev (7:6.3.7.9.dfsg1-2+b2 Debian:testing)
Conf libmagick++9-dev (7:6.3.7.9.dfsg1-2+b2 Debian:testing)
Conf libwpd-stream8c2a (0.8.14-1 Debian:testing)
Conf libwpd8-dev (0.8.14-1 Debian:testing)
Conf libwpg-dev (0.1.2-1 Debian:testing)
Zapisane
Elfica
Użytkownik

Reputacja: 2 Offline Offline

Płeć: Kobieta
GIMP: 2.4
JID: elfiatko@jabster.pl
Licencja: Copyright
Wiadomości: 61
Galeria Użytkownika



Zobacz profil
« Odpowiedz #16 : 05.06.2008, 21:50:34 »

Dzięki za tak wyczerpujący opis :) Naprawdę sporo czasu dzięki Tobie zaoszczędzę. Mi też krzyczał o jakieś biblioteki ale jak je dołożyłam to chciał więcej i więcej aż straciłam cierpliwość :)
Jutro może pogrzebię, bo właśnie zrobiłam ten update i chwilowo zachwycam się nowym KDE :D
Czasami tęsknię za Debiankiem hmm :)
Zapisane

RRH
Gość
« Odpowiedz #17 : 07.06.2008, 15:35:23 »

6. Znalazłem chyba kolejny błąd. Zróbcie tak:

1. Utwórzcie nową warstwę, nazwijcie ją powiedzmy 1 i na niej narysujcie koło. Rozmyjcie to koło promieniem np. 13.
2. Stwórzcie nową warstwę o nazwie 2. Skopiujcie pierwsze koło i zablokujcie tamtą warstwę.
Na warstwie 2 wklejcie w miejscu pochodzenia. Przesuńcie tą warstwę na bok. Rozmyjcie teraz drugie koło promieniem np. 5. I co się dzieje?
Zostaje rozmyte pierwsze koło, pomimo, że jest ono na warstwie zablokowanej.
Wniosek? Obiekt zachowuje się jak klon, chociaż nim nie jest.

Było to próbowane na prawie najnowszej rewizji (albo najnowszej). Sprawdźcie to w swoim Inku.
Zapisane
biazol
Gość
« Odpowiedz #18 : 08.06.2008, 03:11:33 »

Już wiem, czego mi brakuje. Większych możliwości w edycji tekstu. Np. nie mogę zmienić odstępu między znakami (a ostatnio potrzebowałem tej opcji).

Na obrazku widać, że między literami I-T-I są odstępy większe niż między innymi. Musiałem nieźle kombinować, żeby wyrównać.


* logo_editions_K.png (23.54 KB, 525x170 - wyświetlony 545 razy.)
Zapisane
RRH
Gość
« Odpowiedz #19 : 08.06.2008, 10:17:59 »

Jest taka możliwość. Wystarczy zaznaczyć literkę i użyć skrótu Alt+strzałki.
Zapisane
faustissima
Użytkownik

Reputacja: 3 Offline Offline

GIMP: 2.6 + GAP
Licencja: Copyright
Wiadomości: 136
Galeria Użytkownika



Zobacz profil
« Odpowiedz #20 : 08.06.2008, 11:57:10 »

6. Znalazłem chyba kolejny błąd. Zróbcie tak:

1. Utwórzcie nową warstwę, nazwijcie ją powiedzmy 1 i na niej narysujcie koło. Rozmyjcie to koło promieniem np. 13.
2. Stwórzcie nową warstwę o nazwie 2. Skopiujcie pierwsze koło i zablokujcie tamtą warstwę.
Na warstwie 2 wklejcie w miejscu pochodzenia. Przesuńcie tą warstwę na bok. Rozmyjcie teraz drugie koło promieniem np. 5. I co się dzieje?
Zostaje rozmyte pierwsze koło, pomimo, że jest ono na warstwie zablokowanej.
Wniosek? Obiekt zachowuje się jak klon, chociaż nim nie jest.

Było to próbowane na prawie najnowszej rewizji (albo najnowszej). Sprawdźcie to w swoim Inku.

Mi nic takiego się nie dzieje, wszystko ok.
Zapisane
asifalittlezonked
Użytkownik

Reputacja: 6 Offline Offline

Płeć: Kobieta
GIMP: 2.6
Licencja: Copyright
Wiadomości: 280
Galeria Użytkownika



Zobacz profil
« Odpowiedz #21 : 08.06.2008, 12:46:32 »

U mnie też działa. Chyba że wkleiłam jakoś inaczej  Chichot (jak się wkleja w miejscu pochodzenia?! Aaaaa!)
Za to ostatnio działo mi się coś dziwnego z filtrami. Miałam, powiedzmy, rozmyte kółko oraz obiekt z gradientem na jednej warstwie. Na drugiej ścieżka, którą potraktowałam Fractalize. Efekt mi się nie spodobał, cofnęłam, i wtedy nagle zniknął blur z kółka oraz gradient z tamtego obiektu (na zupełnie innej warstwie). Powtarzało się to za każdym razem, kiedy próbowałam cofnąć operację z filtrem, nie tylko Fractalize.
Zapisane
RRH
Gość
« Odpowiedz #22 : 09.06.2008, 19:47:40 »

Hm, faktycznie w Inkscape 0.46, czyli w stabilnym wydaniu tak się nie dzieje. Dzieje się tak jak opisałem w wydaniu rozwojowym. Czekam, aż Elfica skompiluje go i to potwierdzi. Uśmiech
Zapisane
Elfica
Użytkownik

Reputacja: 2 Offline Offline

Płeć: Kobieta
GIMP: 2.4
JID: elfiatko@jabster.pl
Licencja: Copyright
Wiadomości: 61
Galeria Użytkownika



Zobacz profil
« Odpowiedz #23 : 10.06.2008, 14:29:34 »

Elfica utknęła przy lcms... cytuję:
Kod:
[root@Zoltan ~]# yum install lcms
Wczytane wtyczki: refresh-packagekit
Ustawianie procesu instalacji
Analizowanie argumentów instalacji pakietów
Pakiet pasujący do lcms-1.17-4.fc9.x86_64 jest już zainstalowany. Sprawdzanie aktualizacji.
Nie ma niczego do zrobienia
[root@Zoltan ~]# yum install lcms-devel
Wczytane wtyczki: refresh-packagekit
Ustawianie procesu instalacji
Analizowanie argumentów instalacji pakietów
Rozwiązywanie zależności
--> Wykonywanie sprawdzania transakcji
---> Pakiet lcms-devel.x86_64 0:1.17-4.fc9 zostanie zaktualizowany
--> Przetwarzanie zależności: lcms-libs = 1.17-4.fc9 dla pakietu: lcms-devel
--> Zakończono rozwiązywanie zależności
lcms-devel-1.17-4.fc9.x86_64 z fedora ma problemy z rozwiązywaniem zależności
  --> Brakująca zależność: lcms-libs = 1.17-4.fc9 jest wymagane przez pakiet lcms-devel-1.17-4.fc9.x86_64 (fedora)
Błąd: Brakująca zależność: lcms-libs = 1.17-4.fc9 jest wymagane przez pakiet lcms-devel-1.17-4.fc9.x86_64 (fedora)

Żeby było śmieszniej
Kod:
[root@Zoltan install]# rpm -ihv lcms-1.17-4.fc9.x86_64.rpm
Przygotowywanie...          ########################################### [100%]
pakiet lcms-1.17-5.fc9.x86_64 (nowszy niż lcms-1.17-4.fc9.x86_64) jest już zainstalowany
plik /usr/bin/icc2ps z instalacji lcms-1.17-4.fc9.x86_64 jest w konflikcie z plikiem z pakietu lcms-1.17-5.fc9.x86_64
plik /usr/bin/icclink z instalacji lcms-1.17-4.fc9.x86_64 jest w konflikcie z plikiem z pakietu lcms-1.17-5.fc9.x86_64
plik /usr/bin/icctrans z instalacji lcms-1.17-4.fc9.x86_64 jest w konflikcie z plikiem z pakietu lcms-1.17-5.fc9.x86_64
plik /usr/bin/jpegicc z instalacji lcms-1.17-4.fc9.x86_64 jest w konflikcie z plikiem z pakietu lcms-1.17-5.fc9.x86_64
plik /usr/bin/tiffdiff z instalacji lcms-1.17-4.fc9.x86_64 jest w konflikcie z plikiem z pakietu lcms-1.17-5.fc9.x86_64
plik /usr/bin/tifficc z instalacji lcms-1.17-4.fc9.x86_64 jest w konflikcie z plikiem z pakietu lcms-1.17-5.fc9.x86_64
plik /usr/bin/wtpt z instalacji lcms-1.17-4.fc9.x86_64 jest w konflikcie z plikiem z pakietu lcms-1.17-5.fc9.x86_64

A próba odinstalowania nowszej wersji (coby zainstalować starszą) kończy się tak, że chce mi wywalić całe KDE z przyległościami... no co ja robię źle?

PS: Zazdroszczę Debiana.. jak tak dalej pójdzie to wrócę niczym ta córka marnotrawna.. tylko się boję bo z 64bitowym Debiankiem też są niezłe przygody ... ech życie...

Edit:
Na moim stabilnym Inkscape'ie numer z kołem bez zastrzeżeń, tzn nie ma żadnych błędów o których piszesz... wersji rozwojowej nie sprawdzę z przyczyn powyżej wspomnianych ech... szkoda :/
Zapisane

RRH
Gość
« Odpowiedz #24 : 10.06.2008, 17:26:34 »

Ja bym na Twoim miejscu założył temat na forum Fedory. Ja tak zawsze robię, jak nie mogę sobie dłużej z czymś poradzić. W większości przypadków dostaję odpowiedź. Zawsze znajdzie się ktoś lepszy. Warto spróbować, tym bardziej, że problem jest racze standardowy. Uśmiech
Zapisane
@Cakper
Administrator

Reputacja: 36 Offline Offline

Płeć: Mężczyzna
GIMP: 2.6 + GAP
JID: cakper@jabber.org
Licencja: CC-NC-BY-SA
Wiadomości: 1 046
Galeria Użytkownika



Zobacz profil WWW
« Odpowiedz #25 : 10.06.2008, 18:46:28 »

RRH: ja dzis skompiluje inkscape z SVN i sprawdze czy jest tak jak mowisz Uśmiech
Zapisane
Elfica
Użytkownik

Reputacja: 2 Offline Offline

Płeć: Kobieta
GIMP: 2.4
JID: elfiatko@jabster.pl
Licencja: Copyright
Wiadomości: 61
Galeria Użytkownika



Zobacz profil
« Odpowiedz #26 : 10.06.2008, 22:01:59 »

RRH, jutro najprawdopodobniej będę już miała Debiana, bo niestety ta Fedora 9 nie sprawdza się zupełnie i nie dotyczy to tylko tej kompilacji...
[chyba że instalator nie ruszy jak ostatnio... co za lajf :)]
PS: Bezproblemowi szczęściarze wy :P :D
Zapisane

faustissima
Użytkownik

Reputacja: 3 Offline Offline

GIMP: 2.6 + GAP
Licencja: Copyright
Wiadomości: 136
Galeria Użytkownika



Zobacz profil
« Odpowiedz #27 : 11.06.2008, 11:06:10 »

Już wiem, czego brakuje mi najbardziej - instrukcji obługi nowych filtrów i efektów. Dla mnie to nadal czarna magia i po prostu nie korzystam, a szkoda (przypomniał mi to Twój artykuł RRH).
Zapisane
Strony: 1 [2] 3 4  Wszystkie
DrukujPobierz PDF
Polskie Forum Użytkowników GIMP-aOgólne dyskusjeDyskusjeInkscapeWątek: Czego Wam brakuje, co chcielibyście zmienić
Skocz do: