Witamy, Gość. Zaloguj się lub zarejestruj.
Czy dotarł do Ciebie email aktywacyjny?


Zaloguj się podając nazwę użytkownika, hasło i długość sesji

Strony: [1] 2  Wszystkie
DrukujPobierz PDF
Autor Wątek: Instalacja GIMP-a w Linuksie  (Przeczytany 41043 razy)
0 użytkowników i 1 Gość przegląda ten wątek.
Sufixx
Nowicjusz

Reputacja: 9 Offline Offline

Płeć: Kobieta
GIMP: 1.*
Licencja: Copyright
Wiadomości: 13
Galeria Użytkownika


---


Zobacz profil WWW
« : 20.09.2006, 16:35:05 »

Witam, oto krótki tutorial opisujący możliwe sposoby instalacji programu GIMP w systemach Linux.

A więc, mamy do wyboru w zasadzie 2 sposoby zainstalowania programu:
 1. Zainstalować skompilowany, gotowy do użycia program z paczki rpm
 2. Skompilować własnoręcznie program (dłuższa i trudniejsza metoda, jednak lepsza)

#####################################################

1. Paczkę z GIMP'em możemy wyszukać i pobrać na jednej z poniższych stron:

http://rpm.pbone.net/
http://freshrpms.net/
http://rpm.livna.org/
http://rpmfind.net/
http://fr.rpmfind.net/
http://fr2.rpmfind.net/

[Należy oczywiście wybrać paczkę odpowiednią dla swojej dystrybucji oraz architektury komputera (z wyjątkiem paczek oznaczonych ,,noarch'')]


Ściągniętą paczkę instalujemy:
Kod:
rpm -ivh nazwapaczki.rpm
Opcja i-instaluje, v-wyświetla wzystko co się dzieje, h-wyświetla pasek postępu.

...można też zainstalować z repozytorium naszej dystrybucji, przy użyciu dostępnego w niej narzędzia zarządzania pakietami. W przypadku SuSE będzie to YaST, w Mandrivie urpmi, w Fedorze yum, w PLD poldek, w debianie APT, a często w różnych dystrybucjach także smart.

No i mamy GIMP'a.

#####################################################

2. Kompilacja GIMP'a. Jest o tyle lepsza, iż skompilowany program ma znacznie większe szanse działać poprawnie, ponieważ jest skompilowany pod nasz system i komputer, co nie zawsze jest możliwe w przypadku gotowych paczek rpm. Jednak jest także dla początkujących użytkowników nieraz trudniejsza, z podowu czasem niespełnionych zależności. W niektórych dytrybucjach kompilacja jest jedyną metodą, ponieważ nie posiadają one systemu pakietów.
Warto wiedzieć że w przypadku wyjscia nowej wersji programu, zawsze wcześniej od paczek pojawiają się jego źródła.

Jednak przejdźmy do rzeczy.

Ściągamy najpierw źródła żądanej wersji GIMP'a z serwera ftp:
ftp://ftp.gimp.org/pub/gimp/

No i jazda!

#Ściągamy przy użyciu wget'a
Kod:
[tails@dom ~]$ wget ftp://ftp.gimp.org/pub/gimp/v2.2/gimp-2.2.11.tar.gz

100%[==========================================================>] 18,545,578    31.91K/s    ETA 00:00

15:20:36 (30.82 KB/s) - `gimp-2.2.11.tar.gz' saved [18545578]

#Wypakowujemy archiwum
Kod:
[tails@dom ~]$ tar -xzf gimp-2.2.11.tar.gz

#Wchodzimy do wypakowanego katalogu
Kod:
[tails@dom ~]$ cd gimp-2.2.11/

#Jeśli jesteśmy ciekawscy i chcemy dobrać sobie opcje, wyświetlamy pomoc dla configure, aby zobaczyć dostępne opcje
Kod:
[tails@dom gimp-2.2.11]$ ./configure --help

#Jeśli nie, po prostu walimy configure
Kod:
[tails@dom gimp-2.2.11]$ ./configure
#W moim przypadku użyłem opcji --without-libtiff --disable-print, ponieważ nie były spełnione owe zależności, a instalować mi się ich nie chciało.

#Jeśli konfiguracja przebiegła bezbłędnie, możemy zacząć kompilację
Kod:
[tails@dom gimp-2.2.11]$ make
#To najdłuższy etap, im wolniejszy komputer, tym dłużej poczekamy

#Gdy kompilacja się zakończy bez problemów, wchodzimy na roota i instalujemy
Kod:
[tails@dom gimp-2.2.11]$ su
Password:
[root@dom gimp-2.2.11]# make install

I oto koniec, możemy się cieszyć GIMP'em Uśmiech



Jeśli przy configure krzyczy nam o różne zależności, lub jesteśmy cierpliwi i pragniemy poeksperymentować z developerskim GIMP'em 2.3.x, będzie nam potrzebne nowsze gtk, glib itp.

?ródła tych bibliotek można znaleść do pobrania tu:
ftp://ftp.gtk.org/pub/

W przypadku jakichkolwiek trudności polecam wyszukiwarkę http://google.pl oraz grupy dyskusyjne google.




« Ostatnia zmiana: 06.06.2009, 15:05:16 wysłane przez INSEKT » Zapisane
mag9lubuskie
Nowicjusz

Reputacja: 3 Offline Offline

Wiadomości: 1
Galeria Użytkownika

mag9lubuskie


Zobacz profil
« Odpowiedz #1 : 24.09.2006, 01:23:34 »

Debianowcom starczy:

Kod:
apt-get install gimp

podrawiam
Zapisane
Graba
Nowicjusz

Reputacja: 3 Offline Offline

Płeć: Mężczyzna
GIMP: 2.6
Licencja: CC-NC-BY-SA
Wiadomości: 11
Galeria Użytkownika



Zobacz profil
« Odpowiedz #2 : 11.03.2007, 01:14:14 »

Albo sciagnac paczke .deb i zainstalowac poleceniem

Kod:
dpkg -i {nazwa sciagnietej paczki}

Zapisane

Are you sure you feel the real
The real thing I hate
All the good things all the bad things
That's all belong to us
Our story is a simple story
We are walking on the border line
grizz
Użytkownik

Reputacja: 3 Offline Offline

Płeć: Mężczyzna
GIMP: 1.*
JID: grizz@jabster.pl
Licencja: Copyright
Wiadomości: 15
Galeria Użytkownika



Zobacz profil WWW
« Odpowiedz #3 : 11.03.2007, 09:19:39 »

Jak masz PLD:

Kod:
poldek -i gimp

Jak masz Archa
Kod:
pacman -S gimp
Zapisane

#==||==========================[ http://grizz.pl/ ]========================-
Studencka wyprawa do Chin http://chiny2009.pl/
===[ http://galeria.firlej.org/ ]=====================-
@Cakper
Administrator

Reputacja: 36 Offline Offline

Płeć: Mężczyzna
GIMP: 2.6 + GAP
JID: cakper@jabber.org
Licencja: CC-NC-BY-SA
Wiadomości: 1 046
Galeria Użytkownika



Zobacz profil WWW
« Odpowiedz #4 : 11.03.2007, 15:16:56 »

Polecam czasem do wiki zaglądnąć gdzie jest to bardzo dokładnie opisane
http://wiki.gimpuj.info/Instalacja
Zapisane
Amman
Nowicjusz

Reputacja: 2 Offline Offline

Płeć: Mężczyzna
GIMP: 2.6
Licencja: CC-BY
Wiadomości: 8
Galeria Użytkownika


Mega Newbie


Zobacz profil
« Odpowiedz #5 : 05.02.2008, 18:54:44 »

Hmm... Ciekawe, na szczęście nie musiałem tego robić, gdyż w Ubuntu domyślnie mam GIMP'a 2.2 Chichot
Ale mam pytanie: co z GAP'em? ściągnąłem jedną z wersji tutaj z gimpuj.info, lecz podczas "./configure" wyskakuje mi takie coś:
Kod:
checking for GIMP... configure: error: Package requirements (gimp-2.0 >= 2.4.0 gimpui-2.0 >= 2.4.0 gimpthumb-2.0 >= 2.4.0) were not met:

No package 'gimp-2.0' found
No package 'gimpui-2.0' found
No package 'gimpthumb-2.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GIMP_CFLAGS
and GIMP_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


Czy ktoś mógłby mi pomóc lub chociaż przetłumaczyć co to znaczy, bo ja w Linuxie nowy jestem...
Zapisane
Kifer71
Gość
« Odpowiedz #6 : 05.02.2008, 19:07:55 »

Jedyne wyjście to doinstalowanie gimp-devel, albo szukanie gotowej paczki z GAP 2.2 np na repozytoriach Debiana. Poza tym po co ci stary Gimp. Zainstaluj 2.4
Zapisane
Amman
Nowicjusz

Reputacja: 2 Offline Offline

Płeć: Mężczyzna
GIMP: 2.6
Licencja: CC-BY
Wiadomości: 8
Galeria Użytkownika


Mega Newbie


Zobacz profil
« Odpowiedz #7 : 05.02.2008, 19:16:09 »

O właśnie. Tak szukałem po wszystkich stronach internetowych że zapomniałem o najprostszej metodzie - repozytoriach. Dziękuję, już mam. Co do instalacji 2.4 - jakoś od dłuższego czasu pracowałem na 2.2 na Winzgrozie i coś czuję, że ciężko mi będzie się przestawić.
Zapisane
Wraithulek
Użytkownik

Reputacja: 2 Offline Offline

Płeć: Mężczyzna
GIMP: 2.6
Licencja: CC-NC-BY-SA
Wiadomości: 73
Galeria Użytkownika


Pffr.


Zobacz profil
« Odpowiedz #8 : 11.12.2008, 15:24:40 »

A skąd mogę wziąć GIMP'a 2.6 po polsku?
(nie umiem kompilować i chcę z jednego kompa na drugi skopiować)
Mam Linux'a Ubuntu 8.04 po angielsku. Proszę o szybką odpowiedź.
Zapisane

W budowie.
mmiicc
√ ι ק

Reputacja: 14 Offline Offline

Płeć: Mężczyzna
GIMP: 2.6
Licencja: CC-BY-SA
Wiadomości: 1 424
Galeria Użytkownika



Zobacz profil WWW
« Odpowiedz #9 : 11.12.2008, 16:10:04 »

Zmień sobie język w ustawieniach systemu na polski to GIMP też będzie po polsku.
Zapisane

Śledź gimptools.pl na  lub Identi.ca
Wraithulek
Użytkownik

Reputacja: 2 Offline Offline

Płeć: Mężczyzna
GIMP: 2.6
Licencja: CC-NC-BY-SA
Wiadomości: 73
Galeria Użytkownika


Pffr.


Zobacz profil
« Odpowiedz #10 : 11.12.2008, 16:38:08 »

Mam ustawiony polski i dalej po angielsku Skwaszony
Z góry dzięki za pomoc.
Zapisane

W budowie.
Sueroski
Nowicjusz

Reputacja: 0 Offline Offline

GIMP: 2.6
Licencja: Copyright
Wiadomości: 10
Galeria Użytkownika



Zobacz profil WWW
« Odpowiedz #11 : 21.04.2010, 14:42:53 »

dodam jeszcze, że debianowcy tylko:
Kod:
apt-get install gimp

a ubuntu'owcy (gimp jest standardowo, jednak jeśli macie jakąś wersje mini itp. ):
Kod:
sudo apt-get install gimp

mimo wszystko poradnik może się przydać (nie w każdym Linux'ie można wyręczyć się apt-get itp. )
Zapisane
Terrqge
Emeryt

Reputacja: 17 Offline Offline

Płeć: Mężczyzna
GIMP: 2.6
Licencja: Copyright
Wiadomości: 1 353
Galeria Użytkownika



Zobacz profil
« Odpowiedz #12 : 21.04.2010, 14:48:47 »

dodam jeszcze, że debianowcy tylko:
Kod:
apt-get install gimp

a ubuntu'owcy (gimp jest standardowo, jednak jeśli macie jakąś wersje mini itp. ):
Kod:
sudo apt-get install gimp

mimo wszystko poradnik może się przydać (nie w każdym Linux'ie można wyręczyć się apt-get itp. )
Jaka znowu wersja mini? A tak w ogóle to od Ubuntu 10.04 nie ma już GIMP'a.
Zapisane

Dropson
Użytkownik

Reputacja: -9 Offline Offline

Płeć: Mężczyzna
GIMP: 2.6
Licencja: Copyright
Wiadomości: 307
Galeria Użytkownika

Dropson


Zobacz profil
« Odpowiedz #13 : 21.04.2010, 15:46:58 »

Yyy po co się bawić skoro Gimp jest już zainstalowany w systemach Ubuntu, Fedora i Gentoo? ;>

Nawet jeśli go zabraknie jest w repo więc tutorial pokazuje jak zainstalować go okrężną drogą, a chyba po to tutoriale nie służą, nieprawdaż?
Zapisane
Strony: [1] 2  Wszystkie
DrukujPobierz PDF
Polskie Forum Użytkowników GIMP-aTutorialeTutorialeGIMPTechniczneWątek: Instalacja GIMP-a w Linuksie
Skocz do: